summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-08 19:56:54 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-08 20:04:12 +0100
commit71e0f1e9adbce4a6476a70bddabf13f6d7af2d40 (patch)
tree9ba57fdc06df9c9b55557e228f8c46dd508bca6d /gnu
parente7e315c02ec2165c31b250770b848fe37f358d9d (diff)
downloadguix-71e0f1e9adbce4a6476a70bddabf13f6d7af2d40.tar.gz
gnu: util-linux: Add variant with udev support.
* gnu/packages/linux.scm (util-linux)[properties]: New field.
(util-linux+udev): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 501a010b25..3c720f32fc 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -15,7 +15,7 @@
 ;;; Copyright © 2016, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016 David Craven <david@craven.ch>
 ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
-;;; Copyright © 2016, 2017, 2018, 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2016, 2018 Rene Saavedra <pacoon@protonmail.com>
 ;;; Copyright © 2016 Carlos Sánchez de La Lama <csanchezdll@gmail.com>
 ;;; Copyright © 2016, 2017 ng0 <ng0@n0.is>
@@ -1182,12 +1182,26 @@ providing the system administrator with some help in common tasks.")
 utilities.  It provides dmesg and includes tools for working with file systems,
 block devices, UUIDs, TTYs, and many other tools.")
 
+    ;; Hide the package so that end users get the udev-enabled variant below.
+    (properties '((hidden? . #t)))
+
     ;; Note that util-linux doesn't use the same license for all the
     ;; code.  GPLv2+ is the default license for a code without an
     ;; explicitly defined license.
     (license (list license:gpl3+ license:gpl2+ license:gpl2 license:lgpl2.0+
                    license:bsd-4 license:public-domain))))
 
+;; util-linux optionally supports udev, which allows lsblk to read file system
+;; metadata without special privileges.  Add it as a separate package to avoid
+;; a circular dependency, and to keep the size small.
+(define-public util-linux+udev
+  (package/inherit
+   util-linux
+   (inputs
+    `(("udev" ,eudev)
+      ,@(package-inputs util-linux)))
+   (properties (alist-delete 'hidden? (package-properties util-linux)))))
+
 (define-public ddate
   (package
     (name "ddate")