summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-05-20 00:56:19 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-20 05:56:54 +0200
commit72faca2c50d1e8a1a39ee334a24333fe09352a6c (patch)
tree1d5e5a8ba8e219cf6fa322af1a48fb4567e18a9c /gnu
parent5a4d48af52e28e97eac07c40548764ffe03dd6b4 (diff)
downloadguix-72faca2c50d1e8a1a39ee334a24333fe09352a6c.tar.gz
gnu: xonsh: Update to 0.9.18.
* gnu/packages/shells.scm (xonsh): Update to 0.9.18.
[snippet]: Adapt to more aggressive bundling.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/shells.scm20
1 files changed, 15 insertions, 5 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 5c8c4b5d8a..fa3eccabd4 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -493,21 +493,31 @@ ksh, and tcsh.")
 (define-public xonsh
   (package
     (name "xonsh")
-    (version "0.6.2")
+    (version "0.9.18")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "xonsh" version))
         (sha256
           (base32
-            "0c2bbmdg0n10q54vq9k1z5n53l0mh1hb1q5xprfhilvrbr6hlcwr"))
+            "1h4rrwzwiwkyi9p49sjn97rl39fqq2r23hchzsw0s3fcwa7m8fkj"))
         (modules '((guix build utils)))
         (snippet
          `(begin
-            ;; Delete bundled ply.
+            ;; Delete bundled PLY.
             (delete-file-recursively "xonsh/ply")
-            (substitute* '("setup.py")
-              (("'xonsh\\.ply\\.ply',") ""))
+            (substitute* "setup.py"
+              (("\"xonsh\\.ply\\.ply\",") ""))
+            ;; Use our properly packaged PLY instead.
+            (substitute* (list "setup.py"
+                               "tests/test_lexer.py"
+                               "xonsh/__amalgam__.py"
+                               "xonsh/lexer.py"
+                               "xonsh/parsers/base.py"
+                               "xonsh/xonfig.py")
+              (("from xonsh\\.ply\\.(.*) import" _ module)
+               (format #f "from ~a import" module))
+              (("from xonsh\\.ply import") "import"))
             #t))))
     (build-system python-build-system)
     (arguments