summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-23 14:03:10 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-23 14:03:37 +0200
commit7635279100147fc7cec97e0c0046f5871c26f380 (patch)
tree0742b3288683c1b1d1442ca9ca1272a1adbfbeab /gnu
parentfa6b5f5043c098f8ce0c7b73c9b7e4688cc33034 (diff)
downloadguix-7635279100147fc7cec97e0c0046f5871c26f380.tar.gz
gnu: xen: Fix upstream hash mismatch.
* gnu/packages/virtualization.scm (xen)[native-inputs]: Fetch mini-os by
Git its commit rather than an unstable tag.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/virtualization.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index ecde4aec9e..15040d65a8 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -2008,7 +2008,7 @@ DOS or Microsoft Windows.")
 (define-public xen
   (package
     (name "xen")
-    (version "4.14.1")
+    (version "4.14.1")               ; please update the mini-os input as well
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -2185,10 +2185,12 @@ override CC = " (assoc-ref inputs "cross-gcc") "/bin/i686-linux-gnu-gcc"))
          (method git-fetch)
          (uri (git-reference
                (url "https://xenbits.xen.org/git-http/mini-os.git")
-               (commit (string-append "xen-RELEASE-" version))))
+               ;; This corresponds to (string-append "xen-RELEASE-" version))
+               ;; at time of packaging, but upstream has unfortunately modified
+               ;; existing tags in the past.
+               (commit "0b4b7897e08b967a09bed2028a79fabff82342dd")))
          (sha256
-          (base32
-           "1i8pcl19n60i2m9vlg79q3nknpj209c9ic5x10wxaicx45kc107f"))
+          (base32 "1i8pcl19n60i2m9vlg79q3nknpj209c9ic5x10wxaicx45kc107f"))
          (file-name "mini-os-git-checkout")))
        ("perl" ,perl)
        ; TODO: markdown