summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Le Bihan <eric.le.bihan.dev@free.fr>2016-07-28 20:05:56 +0200
committerLudovic Courtès <ludo@gnu.org>2016-07-29 17:29:50 +0200
commit798b776deb2b0dd7dbadebfad62989693808daa8 (patch)
treed4f3faa56df7a78bf2fee53ccea2c1fa9b22182c /gnu
parent918cee467da691cbd6a1788eb4de1782bff61e61 (diff)
downloadguix-798b776deb2b0dd7dbadebfad62989693808daa8.tar.gz
gnu: Add s6-dns.
* gnu/packages/skarnet.scm (s6-dns): New variable.

Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/skarnet.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/skarnet.scm b/gnu/packages/skarnet.scm
index 59c37822a6..84f87e63a3 100644
--- a/gnu/packages/skarnet.scm
+++ b/gnu/packages/skarnet.scm
@@ -131,3 +131,33 @@ different sets of independent tools that can be used within or without the
 framework, and that can be assembled together to achieve powerful
 functionality with a very small amount of code.")))
 
+(define-public s6-dns
+  (package
+   (name "s6-dns")
+   (version "2.0.1.0")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append "http://skarnet.org/software/s6-dns/s6-dns-"
+                         version ".tar.gz"))
+     (sha256
+      (base32
+       "1ji47iy8czx4jmi763dxd6lgjbnp4vqqgcijh46ym65l0a97z04w"))))
+    (build-system gnu-build-system)
+    (inputs `(("skalibs" ,skalibs)))
+    (arguments
+     '(#:configure-flags (list
+                          (string-append "--with-lib="
+                                         (assoc-ref %build-inputs "skalibs")
+                                         "/lib/skalibs")
+                          (string-append "--with-sysdeps="
+                                         (assoc-ref %build-inputs "skalibs")
+                                         "/lib/skalibs/sysdeps"))
+       #:tests? #f))
+    (home-page "http://skarnet.org/software/s6-dns")
+    (license isc)
+    (synopsis "Suite of DNS client programs")
+    (description
+     "s6-dns is a suite of DNS client programs and libraries for Unix systems,
+as an alternative to the BIND, djbdns or other DNS clients.")))
+