summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-26 20:56:03 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-26 20:56:03 +0200
commit83612310191bd4ea86b37784f7de61d4a8e11e05 (patch)
treeae7e069209e2a685f4f43d6c90023b1b2a516ea2 /gnu
parentb495fbfad9cd04ffe387d812fc126777bdf6e40d (diff)
downloadguix-83612310191bd4ea86b37784f7de61d4a8e11e05.tar.gz
gnu: emacs-rsw-elisp: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-rsw-elisp)[source]: Download using
git-fetch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a4eed54127..f124dc3a76 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14056,13 +14056,14 @@ split to display more windows and more buffers, the buffer exits
     (name "emacs-rsw-elisp")
     (version "1.0.5")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/rswgnu/rsw-elisp"
-                                  "/archive/" version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/rswgnu/rsw-elisp")
+                     (commit version)))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1jnn7xfwl3wxc87v44ccsf1wwp80par3xgcvfb1icd6zchjmlcps"))))
+                "0dfq8myg0r91900bk1s70amsmm4mjk2qsg12v5pk7lla5d2vnyaf"))))
     (build-system emacs-build-system)
     (home-page "https://github.com/rswgnu/rsw-elisp")
     (synopsis "Improved expressions that interactively evaluate Emacs Lisp")