summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:01:10 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:39 +0200
commit8524d13011e7ca010df2cf9aa4c0f35310a31482 (patch)
treee1bddea8df5b3fb4bcd4341668a976c08bea92f0 /gnu
parent768fea0fd4b77d765472576f13ccf17e25182271 (diff)
downloadguix-8524d13011e7ca010df2cf9aa4c0f35310a31482.tar.gz
gnu: python-honcho: Don't use unstable tarball.
* gnu/packages/python-xyz.scm (python-honcho)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ae3d8427ce..373be2a82c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4487,13 +4487,13 @@ cluster without needing to write any wrapper code yourself.")
     (version "1.0.1")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://github.com/nickstenning/honcho/archive/v"
-             version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/nickstenning/honcho.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "0zizn61n5z5hq421hkypk9pw8s6fpxw30f4hsg7k4ivwzy3gjw9j"))))
+        (base32 "11bd87474qpif20xdcn0ra1idj5k16ka51i658wfpxwc6nzsn92b"))))
     (build-system python-build-system)
     (native-inputs
      `(("python-pytest" ,python-pytest)