summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-08-07 20:22:15 +0200
committerDavid Craven <david@craven.ch>2016-08-30 22:38:31 +0200
commit85e831ec0c05bc4f3f9c9ef010be0a5139187719 (patch)
treec9d577bb8c9926db28858dabbc9065d7e048b47b /gnu
parent6609b1a3948f5bd861d895c3297ef4d1768390f3 (diff)
downloadguix-85e831ec0c05bc4f3f9c9ef010be0a5139187719.tar.gz
gnu: Add kpeople.
* gnu/packages/kde-frameworks.scm (kpeople): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 5a46aee324..11c019321b 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2278,3 +2278,45 @@ notifications which can be embedded in your application.")
     (description "This library implements the framework for KDE parts, which are
 widgets with a user-interface defined in terms of actions.")
     (license license:lgpl2.1+)))
+
+(define-public kpeople
+  (package
+    (name "kpeople")
+    (version "5.24.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/frameworks/"
+                           (version-major+minor version) "/"
+                           name "-" version ".tar.xz"))
+       (sha256
+        (base32
+         "0iknzkj23y927xh24kw5sjxyirhy6pkmfcmmgwzd78rba8a54qp2"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)))
+    (inputs
+     `(("kconfig" ,kconfig)
+       ("kcoreaddons" ,kcoreaddons)
+       ("kitemviews" ,kitemviews)
+       ("ki18n" ,ki18n)
+       ("kservice" ,kservice)
+       ("kwidgetsaddons" ,kwidgetsaddons)
+       ("qtbase" ,qtbase)
+       ("qtdeclarative" ,qtdeclarative)))
+    (arguments
+     `(#:tests? #f ; FIXME: 1/3 tests fail.
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'check-setup
+           (lambda _
+             (setenv "CTEST_OUTPUT_ON_FAILURE" "1") ; Enable debug output
+             (setenv "QT_QPA_PLATFORM" "offscreen"))))))
+    (home-page "https://community.kde.org/Frameworks")
+    (synopsis "Provides access to all contacts and aggregates them by person")
+    (description "KPeople offers unified access to our contacts from different
+sources, grouping them by person while still exposing all the data.  KPeople
+also provides facilities to integrate the data provided in user interfaces by
+providing QML and Qt Widgets components.  The sources are plugin-based, allowing
+to easily extend the contacts collection.")
+    (license license:lgpl2.1+)))