summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-25 10:00:04 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-25 10:22:26 +0200
commit864cc7ef56d98838de4f7241bd60b345112593c9 (patch)
tree2f261d718faf0f8765be2165d608270c9e1c2e20 /gnu
parent5c7d62242a7f066b5b248beb6b87c94e72813936 (diff)
downloadguix-864cc7ef56d98838de4f7241bd60b345112593c9.tar.gz
gnu: tiled: Use modular Qt.
* gnu/packages/game-development.scm (tiled)[inputs]: Remove qt; add qtbase and
qtsvg.
[native-inputs]: Add qttools.
[arguments]: Override LRELEASE in translations.pro.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/game-development.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index da3a850fed..b7bcdee94c 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -262,13 +262,22 @@ levels.")
                (base32
                 "1kcj2blrlfpghjv0qigip2qcbxfx7vv9i8nr4997hkwhsh6i2pjp"))))
     (build-system gnu-build-system)
-    (inputs `(("qt" ,qt)
-              ("zlib" ,zlib)))
+    (inputs
+     `(("qtbase" ,qtbase)
+       ("qtsvg" ,qtsvg)
+       ("zlib" ,zlib)))
+    (native-inputs
+     `(("qttools" ,qttools)))
     (arguments
      '(#:phases
        (modify-phases %standard-phases
          (replace 'configure
-           (lambda* (#:key outputs #:allow-other-keys)
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (substitute* "translations/translations.pro"
+               (("LRELEASE =.*")
+                (string-append "LRELEASE = "
+                               (assoc-ref inputs "qttools")
+                               "/bin/lrelease\n")))
              (let ((out (assoc-ref outputs "out")))
                (system* "qmake"
                         (string-append "PREFIX=" out))))))))