summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 11:15:07 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:44 +0200
commit86e7f7722053783ea4a14808a9c6d4cc63157e03 (patch)
tree2f3d0a315180272bfa3aa2e4a4c31aaab37f6722 /gnu
parentcf3b2f0772ad0960838f2b4dda986413b108e510 (diff)
downloadguix-86e7f7722053783ea4a14808a9c6d4cc63157e03.tar.gz
gnu: texlive-grffile: Fix build.
* gnu/packages/tex.scm (texlive-grffile)[source]: Set proper locations.
Remove `simple-texlive-package' call.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm46
1 files changed, 20 insertions, 26 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7f7a3bd1df..3b1145d667 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4038,32 +4038,26 @@ the l3kernel and xparse bundles from the LaTeX 3 development team.")
 (define-deprecated-package texlive-latex-fontspec texlive-fontspec)
 
 (define-public texlive-grffile
-  (let ((template (simple-texlive-package
-                   "texlive-grffile"
-                   (list "/doc/latex/grffile/README.md"
-                         "/source/latex/grffile/grffile.dtx")
-                   (base32
-                    "1ib2n4d52faipvxdvdh4ar1p5j997h7cza26sfyd8z3qdf0naqgx"))))
-    (package
-      (inherit template)
-      (arguments
-       (substitute-keyword-arguments (package-arguments template)
-         ((#:tex-directory _ #t)
-          "latex/grffile")
-         ((#:build-targets _ #t)
-          '(list "grffile.dtx"))
-         ((#:phases phases)
-          `(modify-phases ,phases
-             (add-after 'unpack 'chdir
-               (lambda _ (chdir "source/latex/grffile/")))))))
-      (home-page "https://www.ctan.org/pkg/grffile")
-      (synopsis "Extended file name support for graphics (legacy package)")
-      (description
-       "The original grffile package extended the file name processing of the
-@code{graphics} package to support a larger range of file names.  The base
-LaTeX code now supports multiple dots and spaces, and this package by default
-is a stub that just loads @code{graphicx}.")
-      (license license:lppl1.3c+))))
+  (package
+    (name "texlive-grffile")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/grffile/"
+                   "source/latex/grffile/"
+                   "tex/latex/grffile/")
+             (base32
+              "01mlvdhqwfwj1l91jfvkdfbn1hj95rlb6xhwikzx1r8qrz5whw7n")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://www.ctan.org/pkg/grffile")
+    (synopsis "Extended file name support for graphics (legacy package)")
+    (description
+     "The original @code{grffile} package extended the file name processing
+of the @code{graphics} package to support a larger range of file names.  The
+base LaTeX code now supports multiple dots and spaces, and this package by
+default is a stub that just loads @code{graphicx}.")
+    (license license:lppl1.3c+)))
 
 (define-public texlive-stringenc
   (let ((template (simple-texlive-package