summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-27 18:20:07 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-28 13:58:43 +0100
commit881ed3f8680a42327ce4efe7aaab04a2f3e65c6e (patch)
tree15bf4ca395e3fae5080f18a135bcfce73bae18da /gnu
parentbc69104a442e1dd2338397a54a3a80eff170e78f (diff)
downloadguix-881ed3f8680a42327ce4efe7aaab04a2f3e65c6e.tar.gz
gnu: python-extras: Update to 1.0.0.
* gnu/packages/python.scm (python-extras): Update to 1.0.0.
[source](uri): Use PYPI-URI.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 22160bcfaa..f08d93dc78 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1500,19 +1500,17 @@ software.")
 (define-public python-extras
   (package
     (name "python-extras")
-    (version "0.0.3")
+    (version "1.0.0")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append
-             "https://pypi.python.org/packages/source/e/extras/extras-"
-             version ".tar.gz"))
+       (uri (pypi-uri "extras" version))
        (sha256
         (base32
-         "1h7zx4dfyclalg0fqnfjijpn0f793a9mx8sy3b27gd31nr6dhq3s"))))
+         "0khvm08rcwm62wc47j8niyl6h13f8w51c8669ifivjdr23g3cbhk"))))
     (build-system python-build-system)
     (arguments
-     ;; error in setup.cfg: command 'test' has no such option 'buffer'
+     ;; FIXME: Circular dependency on testtools.
      '(#:tests? #f))
     (home-page "https://github.com/testing-cabal/extras")
     (synopsis "Useful extensions to the Python standard library")