summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-10 19:31:43 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-11 02:00:45 +0200
commit895789ea78d4e41d672f72fb519ea32a7a2f408b (patch)
tree79326e60292e6828519c46d7e66b9c082e5fc1e9 /gnu
parentc327bb4463d736045885ca9833d8a328e0dc6a16 (diff)
downloadguix-895789ea78d4e41d672f72fb519ea32a7a2f408b.tar.gz
gnu: po4a: Update to 0.54.
* gnu/packages/gettext.scm (po4a): Update to 0.54.
[arguments]: Remove ‘set-search-path’ and ‘fix-builder’ phases.
Coalesce ‘disable-...-test’ phases into one ‘disable-failing-tests’
phase, update their numbering, and re-enable the ‘yaml’ test.
[native-inputs]: Add perl-yaml-tiny test dependency.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gettext.scm54
1 files changed, 21 insertions, 33 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index f887f8eb30..a90b217bab 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -142,46 +143,18 @@ translated messages from the catalogs.  Nearly all GNU packages use Gettext.")
 (define-public po4a
   (package
     (name "po4a")
-    (version "0.53")
+    (version "0.54")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/mquinson/po4a/releases/download/v"
                                   version "/po4a-" version ".tar.gz"))
               (sha256
                (base32
-                "033qrd37zjjzvjl6g55fvhlcrm7gynfx6rj76qpr2852dn0mw069"))))
+                "0l9xc06cr8i5jqycfylr4lynhmkb4ng2534m14kx37bzd4hpcvsr"))))
     (build-system perl-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (add-before 'configure 'set-search-path
-           (lambda _
-             ;; Work around "dotless @INC" build failure.
-             (setenv "PERL5LIB"
-                     (string-append (getcwd) ":"
-                                    (getenv "PERL5LIB")))
-             #t))
-         ;; FIXME: One test fails as we don't have SGMLS.pm
-         (add-before 'check 'disable-sgml-test
-          (lambda _
-            (delete-file "t/20-sgml.t")
-            #t))
-         (add-before 'check 'disable-asciidoc-test
-           (lambda _
-             (delete-file "t/30-asciidoc.t")
-             #t))
-         (add-before 'check 'disable-yaml-test
-           (lambda _
-             (delete-file "t/32-yaml.t")
-             #t))
-         (add-after 'unpack 'fix-builder
-          (lambda* (#:key inputs outputs #:allow-other-keys)
-            (substitute* "Po4aBuilder.pm"
-              ;; By default it tries to install into perl's manpath.
-              (("my \\$mandir = .*$")
-               (string-append "my $mandir = \"" (assoc-ref outputs "out")
-                              "/share/man\";\n")))
-            #t))
          (add-after 'install 'wrap-programs
           (lambda* (#:key outputs #:allow-other-keys)
             ;; Make sure all executables in "bin" find the Perl modules
@@ -200,15 +173,30 @@ translated messages from the catalogs.  Nearly all GNU packages use Gettext.")
                        (find-files (string-append (assoc-ref outputs "out")
                                                   "/share/man")
                                    ".*\\.gz$"))
+             #t))
+         (add-before 'check 'disable-failing-tests
+           (lambda _
+             ;; FIXME: ‘Files ../t-03-asciidoc/Titles.po and Titles.po differ’.
+             (delete-file "t/03-asciidoc.t")
+
+             ;; FIXME: ‘Unknown format type: html’, and it's not listed.
+             (delete-file "t/09-html.t")
+
+             ;; FIXME: this test requires SGMLS.pm.
+             (delete-file "t/16-sgml.t")
+
              #t)))))
     (native-inputs
      `(("gettext" ,gettext-minimal)
        ("perl-module-build" ,perl-module-build)
        ("docbook-xsl" ,docbook-xsl)
-       ("docbook-xml" ,docbook-xml) ;for tests
-       ("texlive" ,texlive-tiny) ;for tests
        ("libxml2" ,libxml2)
-       ("xsltproc" ,libxslt)))
+       ("xsltproc" ,libxslt)
+
+       ;; For tests.
+       ("docbook-xml" ,docbook-xml)
+       ("perl-yaml-tiny" ,perl-yaml-tiny)
+       ("texlive" ,texlive-tiny)))
     (home-page "https://po4a.org/")
     (synopsis "Scripts to ease maintenance of translations")
     (description