summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-07-12 15:29:55 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-08-08 22:08:17 +1000
commit8a525c3f08d33bdef1f67407b89288ab130a59a2 (patch)
treeefe55dbe2a925af6c6e73df59416179980c2dc99 /gnu
parent5eec378b799912012d1cc55bad64dbb3ac46d8a9 (diff)
downloadguix-8a525c3f08d33bdef1f67407b89288ab130a59a2.tar.gz
gnu: Add perl-file-slurper.
* gnu/packages/perl.scm (perl-file-slurper): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index ffb7c1fd30..7b91a066f8 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2423,6 +2423,29 @@ files with a simple call.  It also has a subroutine for reading the list of
 file names in a directory.")
     (license (package-license perl))))
 
+(define-public perl-file-slurper
+  (package
+    (name "perl-file-slurper")
+    (version "0.008")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/L/LE/LEONT/File-Slurper-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0cyjspspms6zyjcqz9v18dbs574g085h2jzjh41xvsrc1qa8bxhh"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-perlio-utf8_strict" ,perl-perlio-utf8_strict)))
+    (home-page "http://search.cpan.org/dist/File-Slurper")
+    (synopsis "Simple, sane and efficient module to slurp a file")
+    (description "This module provides functions for fast and correct file
+slurping and spewing.  All functions are optionally exported.")
+    (license (package-license perl))))
+
 (define-public perl-file-slurp-tiny
   (package
     (name "perl-file-slurp-tiny")