summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-06-17 04:58:25 -0500
committerEric Bavier <bavier@member.fsf.org>2015-06-29 15:34:36 -0500
commit8c94c886f661ed416c86e539a05ae586c356de52 (patch)
tree03c3eff839cc6e202c1078d8bd444350303cf1b3 /gnu
parent9a899cceab0d0489a03a37a45f01e09a783ba56a (diff)
downloadguix-8c94c886f661ed416c86e539a05ae586c356de52.tar.gz
gnu: Add arpack-ng-openmpi.
* gnu/packages/maths.scm (arpack-ng-openmpi): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 9b2c0ace7f..282d81b310 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -274,6 +274,15 @@ large scale eigenvalue problems.")
     (license (license:non-copyleft "file://COPYING"
                                 "See COPYING in the distribution."))))
 
+(define-public arpack-ng-openmpi
+  (package (inherit arpack-ng)
+    (name "arpack-ng-openmpi")
+    (inputs
+     `(("mpi" ,openmpi)
+       ,@(package-inputs arpack-ng)))
+    (arguments `(#:configure-flags '("--enable-mpi")))
+    (synopsis "Fortran subroutines for solving eigenvalue problems with MPI")))
+
 (define-public lapack
   (package
     (name "lapack")