summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-01 18:18:17 +0200
committerMarius Bakke <marius@gnu.org>2021-06-01 20:21:54 +0200
commit8d14d602ea00a048401472387f282c7cf995d144 (patch)
tree0e2d45c505af8eb3ab05853ae11227bac4d8866e /gnu
parent304895d5e04d6f09a29b3fe233e3a8f6b62fbd8b (diff)
downloadguix-8d14d602ea00a048401472387f282c7cf995d144.tar.gz
gnu: unbound: Enable DoH support.
* gnu/packages/dns.scm (unbound)[inputs]: Add NGHTTP2:LIB.
[arguments]: Add "--with-libnghttp2" to #:configure-flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/dns.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 86185373c4..a0388a1419 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -625,6 +625,7 @@ to result in system-wide compromise.")
     (inputs
      `(("expat" ,expat)
        ("libevent" ,libevent)
+       ("nghttp2" ,nghttp2 "lib")
        ("protobuf" ,protobuf)
        ("python-wrapper" ,python-wrapper)
        ("openssl" ,openssl)))
@@ -632,6 +633,8 @@ to result in system-wide compromise.")
      `(#:configure-flags
        (list "--disable-static" ; save space and non-determinism in libunbound.a
              (string-append
+              "--with-libnghttp2=" (assoc-ref %build-inputs "nghttp2"))
+             (string-append
               "--with-ssl=" (assoc-ref %build-inputs "openssl"))
              (string-append
               "--with-libevent=" (assoc-ref %build-inputs "libevent"))