summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDaniel Pimentel <d4n1@d4n1.org>2016-07-22 02:09:25 -0400
committerLeo Famulari <leo@famulari.name>2016-07-22 02:22:49 -0400
commit8d63dddac11882ef85283bda259e0142b65ae28f (patch)
tree8ba28e975243d53854a11e87b5fd7cd2af3d7965 /gnu
parentd7cff656df0f6cbcb8adcedc6224b50038aee3c9 (diff)
downloadguix-8d63dddac11882ef85283bda259e0142b65ae28f.tar.gz
gnu: Add python-protobuf.
* gnu/packages/protobuf.scm (python-protobuf, python2-protobuf): New variables.

Co-authored-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/protobuf.scm34
1 files changed, 33 insertions, 1 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 03d1edcee7..86c418bb05 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -1,5 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016 Daniel Pimentel <d4n1@d4n1.org>
+;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -20,9 +22,12 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system python)
   #:use-module ((guix licenses)
                 #:select (bsd-3))
-  #:use-module (gnu packages compression))
+  #:use-module (gnu packages compression)
+  #:use-module (gnu packages gcc)
+  #:use-module (gnu packages python))
 
 (define-public protobuf
   (package
@@ -44,3 +49,30 @@
 yet extensible format.  Google uses Protocol Buffers for almost all of its
 internal RPC protocols and file formats.")
     (license bsd-3)))
+
+(define-public python-protobuf
+  (package
+    (name "python-protobuf")
+    (version "3.0.0b4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "protobuf" version))
+       (sha256
+        (base32
+         "18zvvn8cgbcwi85ws2ny0k4qp33wd525spsb8sxvrj325mbx9cpk"))))
+    (build-system python-build-system)
+    (inputs
+     `(("python-six" ,python-six)))
+    (home-page "https://github.com/google/protobuf")
+    (synopsis "Protocol buffers is a data interchange format")
+    (description
+     "Protocol buffers are a language-neutral, platform-neutral extensible
+mechanism for serializing structured data.")
+    (license bsd-3)
+    (properties `((python2-variant . ,(delay python2-protobuf))))))
+
+(define-public python2-protobuf
+  (package (inherit (package-with-python2
+                     (strip-python2-variant python-protobuf)))
+           (native-inputs `(("python2-setuptools" ,python2-setuptools)))))