summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:47:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:22 +0200
commit8e6935ebe210043451322ddd85d18cc855712517 (patch)
tree81c2dc0a0e9043e272671aacc89f3b30bc21011f /gnu
parent56d4b7624586407140430fbb5abf607c42c51f13 (diff)
downloadguix-8e6935ebe210043451322ddd85d18cc855712517.tar.gz
gnu: Add texlive-simplebnf.
* gnu/packages/tex.scm (texlive-simplebnf): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b84d8fe005..577b588be3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6073,6 +6073,26 @@ electrical and electronics engineers and graph theorists.")
 the shuffle product which is used in some part of mathematics and physics.")
     (license license:public-domain)))
 
+(define-public texlive-simplebnf
+  (package
+    (name "texlive-simplebnf")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/simplebnf/"
+                   "tex/latex/simplebnf/")
+             (base32
+              "0a8kysfm24yh738pigwprjjyg0dg2fpf5k549wqi6qx09wp4d3xw")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/simplebnf")
+    (synopsis "Simple package to format Backus-Naur form (BNF)")
+    (description
+     "This package provides a simple way to format Backus-Naur form (BNF).
+The included @code{bnfgrammar} environment parses BNF expressions (possibly
+annotated), so users can write readable BNF expressions in their documents.")
+    (license license:expat)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")