summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-20 18:14:10 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-20 23:51:25 +0200
commit8f85018daaa3548e721c369511a654f5f7753653 (patch)
treed163fc768208d2f0b0066b9d379394fbc362383b /gnu
parent6623a1512333479107c31137efec412d4d9d4585 (diff)
downloadguix-8f85018daaa3548e721c369511a654f5f7753653.tar.gz
gnu: Add ruby-gherkin-ruby.
* gnu/packages/ruby.scm (ruby-gherkin-ruby): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 83dea8d37a..4eb9d0d696 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5698,6 +5698,25 @@ It is intended be used by all Cucumber implementations to parse
     (home-page "https://github.com/cucumber-attic/gherkin")
     (license license:expat)))
 
+(define-public ruby-gherkin-ruby
+  (package
+    (name "ruby-gherkin-ruby")
+    (version "0.3.2")
+    (home-page "http://github.com/codegram/gherkin-ruby")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "gherkin-ruby" version))
+              (sha256
+               (base32
+                "18ay7yiibf4sl9n94k7mbi4k5zj2igl4j71qcmkswv69znyx0sn1"))))
+    (build-system ruby-build-system)
+    (synopsis "Pure Ruby Gherkin parser")
+    (description
+     "Gherkin-ruby is a Gherkin parser written in pure Ruby and less than
+200 lines of code.")
+    ;; XXX: No license information anywhere but Readme.md.
+    (license license:expat)))
+
 (define-public ruby-aruba
   (package
     (name "ruby-aruba")