summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-11-27 14:02:42 +0900
committerClément Lassieur <clement@lassieur.org>2019-12-04 11:06:49 +0100
commit903765f0d9fee0412e63d960f20b741c5afbcea7 (patch)
treeb29aab59f06325a3191e834e8e2509f037c90521 /gnu
parentc320acd633907397bfd3246ba6446d45d2e55ba2 (diff)
downloadguix-903765f0d9fee0412e63d960f20b741c5afbcea7.tar.gz
gnu: emacs: Use load-path instead of EMACSLOADPATH.
This enables the use of the subdirs.el feature of Emacs, where specifying a
directory in EMACSLOADPATH translates into a `load-path' variable containing
the directory and all its sub-directories.

* gnu/packages/aux-files/emacs/guix-emacs.el (guix-emacs-autoload-packages):
Use `load-path' directly instead of parsing EMACSLOADPATH.

Reported-by: Leo Prikler <leo.prikler@student.tugraz.at>
Signed-off-by: Clément Lassieur <clement@lassieur.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/aux-files/emacs/guix-emacs.el5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/aux-files/emacs/guix-emacs.el b/gnu/packages/aux-files/emacs/guix-emacs.el
index b4315c1a2e..05fc9709b6 100644
--- a/gnu/packages/aux-files/emacs/guix-emacs.el
+++ b/gnu/packages/aux-files/emacs/guix-emacs.el
@@ -47,13 +47,12 @@ The files in the list do not have extensions (.el, .elc)."
   ;; FIXME: The autoloads generated by the emacs-build-system are not byte
   ;; compiled.
   (interactive)
-  (let* ((emacs-load-path (getenv "EMACSLOADPATH"))
-         (emacs-non-core-load-path-directories
+  (let* ((emacs-non-core-load-path-directories
           ;; Filter out core Elisp directories, which are already autoloaded
           ;; by Emacs.
           (seq-filter (lambda (dir)
                         (string-match-p "/share/emacs/site-lisp" dir))
-                      (split-string emacs-load-path ":")))
+                      load-path))
          (autoloads (mapcan #'guix-emacs-find-autoloads
                             emacs-non-core-load-path-directories)))
     (mapc (lambda (f)