summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-08-14 13:13:18 +0000
committerEfraim Flashner <efraim@flashner.co.il>2016-09-05 21:17:58 +0300
commit951e924c9b0f34ed57d7676b2f67d520b05b8482 (patch)
treebf5b844ae9977c19b3cd45b47fce45391ed42b71 /gnu
parentba24828805a3904b141a1afb5a5bb1b13b668f22 (diff)
downloadguix-951e924c9b0f34ed57d7676b2f67d520b05b8482.tar.gz
gnu: Add perl-datetime-format-mail.
* gnu/packages/perl.scm (perl-datetime-format-mail): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 4e3d1fa8d0..db941fbf09 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1792,6 +1792,27 @@ to create DateTime objects, with some custom tweaks to smooth out the rough
 edges (mainly concerning timezone detection and selection).")
     (license (package-license perl))))
 
+(define-public perl-datetime-format-mail
+  (package
+    (name "perl-datetime-format-mail")
+    (version "0.403")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://cpan/authors/id/B/BO/BOOK/"
+                                  "DateTime-Format-Mail-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1c7wapbi9g9p2za52l3skhh31vg4da5kx2yfqzsqyf3p8iff7y4d"))))
+    (build-system perl-build-system)
+    (inputs
+     `(("perl-datetime" ,perl-datetime)
+       ("perl-params-validate" ,perl-params-validate)))
+    (home-page "http://search.cpan.org/dist/DateTime-Format-Mail")
+    (synopsis "Convert between DateTime and RFC2822/822 formats")
+    (description "RFCs 2822 and 822 specify date formats to be used by email.
+This module parses and emits such dates.")
+    (license (package-license perl))))
+
 (define-public perl-devel-caller
   (package
     (name "perl-devel-caller")