summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-12-06 02:07:56 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-12-07 17:36:17 +0100
commit9bb798948851f7418475d5da989fd62c26575fd2 (patch)
treee7aca67f6f5f6ab62fc662b48c07d371e5301953 /gnu
parent61bfc18ee8fa084133a6dac500c0f8f037e5d925 (diff)
downloadguix-9bb798948851f7418475d5da989fd62c26575fd2.tar.gz
gnu: sddm: Remove obsolete workaround.
* gnu/packages/display-managers.scm (sddm)[arguments]: Remove obsolete
'fix-qml-include' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/display-managers.scm8
1 files changed, 0 insertions, 8 deletions
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index fcc4f952a1..2f4a8c2d73 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -190,14 +190,6 @@ Qt-style API for Wayland clients.")
              (substitute* "CMakeLists.txt"
                (("/usr/bin/loginctl") (which "loginctl")))
              #t))
-         (add-before 'configure 'fix-qml-include
-           (lambda _
-             ;; Make sure QtQml is found when building the helper.
-             ;; See <https://github.com/sddm/sddm/pull/918>.
-             (substitute* "src/helper/CMakeLists.txt"
-               (("target_link_libraries\\(sddm-helper")
-                "target_link_libraries(sddm-helper Qt5::Qml"))
-             #t))
          (add-after 'install 'wrap-programs
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))