summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-26 20:27:24 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-26 20:27:24 +0200
commit9f00d13d5dc720dbbe1ec95c48a2c8a15c0b40c4 (patch)
tree68ecc38dcdc7d43fbf938aba55eb4d11f4c9f24f /gnu
parent854d4d40fd9bbc41c23bee11f3f25aff95ea863f (diff)
downloadguix-9f00d13d5dc720dbbe1ec95c48a2c8a15c0b40c4.tar.gz
gnu: python-django-jinja: Don't use unstable tarball.
* gnu/packages/django.scm (python-django-jinja)[source]: Download using
git-fetch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/django.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index c47ea44fd4..7e7bc5d002 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -456,14 +456,14 @@ merging, minifying and compiling CSS and Javascript files.")
     (version "2.4.1")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://github.com/niwinz/django-jinja/archive/"
-             version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/niwinz/django-jinja.git")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "0bzrb4m6wx9ph5cpvz7wpvg5k6ksvj0dnxlg0nhhqskhvp46brs1"))))
+         "1fcrxlznlq1xvl26y3j1r22vvy6m08r5l97xi2wj50rdmxhfvhis"))))
     (build-system python-build-system)
     (propagated-inputs
      `(("python-django" ,python-django)