summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2016-12-21 11:47:16 +0000
committerLeo Famulari <leo@famulari.name>2016-12-28 22:41:53 -0500
commita0e41de4abdf23c51924ada15e5d28d6c22d09f2 (patch)
tree9803fd4308a5c9710b69aecc0d299c11a868c38e /gnu
parent03702173f1b4d0dc5578e3554c2501f381a87696 (diff)
downloadguix-a0e41de4abdf23c51924ada15e5d28d6c22d09f2.tar.gz
gnu: Add python-openid-teams.
* gnu/packages/python.scm (python-openid-teams, python2-openid-teams): New
variables.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d61dd6c95e..d74438d930 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5413,6 +5413,28 @@ contributor license agreement extension for python-openid.")
 (define-public python2-openid-cla
   (package-with-python2 python-openid-cla))
 
+(define-public python-openid-teams
+  (package
+    (name "python-openid-teams")
+    (version "1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "python-openid-teams" version))
+       (sha256
+        (base32
+         "05zrh78alav24rxkbqlpbad6d3x2nljk6z6j7kflxf3vdqa7w969"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/puiterwijk/python-openid-teams/")
+    (synopsis "Implementation of the OpenID teams extension for python-openid")
+    (description
+     "@code{openid-teams} is an implementation of the OpenID
+teams extension for python-openid.")
+    (license license:bsd-3)))
+
+(define-public python2-openid-teams
+  (package-with-python2 python-openid-teams))
+
 (define-public python-netifaces
   (package
     (name "python-netifaces")