summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-27 18:50:07 +0100
committerLeo Famulari <leo@famulari.name>2021-12-28 14:10:23 -0500
commita2e0731375ddd532bf39871f001cf1e92b7f48a5 (patch)
treea4acf2252c0132abc07ea8d2d4e59292e88e7088 /gnu
parentd50b209810b41be158e23e8e1528ac876e4f8080 (diff)
downloadguix-a2e0731375ddd532bf39871f001cf1e92b7f48a5.tar.gz
gnu: Add rust-embedded-hal-0.2.
* gnu/packages/crates-io.scm (rust-embedded-hal-0.2): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3e661e54bb..d2f7657348 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -16836,6 +16836,29 @@ and authentication, easy email builders, and async support.")
 inclusion of Windows resources in the most resilient fashion imaginable.")
     (license license:expat)))
 
+(define-public rust-embedded-hal-0.2
+  (package
+    (name "rust-embedded-hal")
+    (version "0.2.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "embedded-hal" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1faa71mvs9zklyiiy9l5br9f2bwmxwak0br7jb49cr8mzxignv73"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-nb" ,rust-nb-0.1)
+        ("rust-void" ,rust-void-1))))
+    (home-page "https://github.com/rust-embedded/embedded-hal")
+    (synopsis "Hardware Abstraction Layer (HAL) for embedded systems")
+    (description "This package provides a Hardware Abstraction Layer (HAL) for
+embedded systems.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-ena-0.14
   (package
     (name "rust-ena")