summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-03-20 11:21:14 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-03-20 18:27:44 +0200
commita39aac3352bf81f9ed7d4bc25dab650be8bdfedb (patch)
tree56def2880b962eb7dc15e379b0b9dfd1b03dd79c /gnu
parent6ec585fb3ec6cbbccdc5cfafa1c8e93acc014c51 (diff)
downloadguix-a39aac3352bf81f9ed7d4bc25dab650be8bdfedb.tar.gz
gnu: Add python-google-auth-httplib2.
* gnu/packages/python-web.scm (python-google-auth-httplib2): New
variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 876947bcc2..93e0c830a9 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4859,6 +4859,27 @@ Google search engine.  Its module is called @code{googlesearch}.")
     (description "Python client library for Google's discovery based APIs")
     (license license:asl2.0)))
 
+(define-public python-google-auth-httplib2
+  (package
+    (name "python-google-auth-httplib2")
+    (version "0.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "google-auth-httplib2" version))
+              (sha256
+               (base32 "1b1hrhah01hx6bj3rb83iybrdwqv0bbdy63py39srv1bcgykjz50"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     (list python-google-auth python-httplib2 python-six))
+    (native-inputs
+     (list python-flask python-mock python-pytest python-pytest-localserver))
+    (home-page
+     "https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2")
+    (synopsis "Google Authentication Library: httplib2 transport")
+    (description "This package provides a Google Authentication Library plugin
+for httplib2 transport.")
+    (license license:asl2.0)))
+
 (define-public whoogle-search
   (package
     (name "whoogle-search")