summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 15:37:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:21 +0200
commita4d7679a5e8944f8de28965ef5ba0d617dcc3c62 (patch)
tree1da1d45b857012bc997aae63e5a5116498b34fc8 /gnu
parenta87ed15e1dee32d94e12714ac0d939a2466125b7 (diff)
downloadguix-a4d7679a5e8944f8de28965ef5ba0d617dcc3c62.tar.gz
gnu: Add texlive-clrscode.
* gnu/packages/tex.scm (texlive-clrscode): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9968b8bd52..2c560234fa 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2505,6 +2505,27 @@ leading journals.  It also provides some handy chemistry-related macros.")
 Interfaces for Plain TeX, ConTeXt and LaTeX are provided.")
     (license license:lppl1.3+)))
 
+(define-public texlive-clrscode
+  (package
+    (name "texlive-clrscode")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/clrscode/" "tex/latex/clrscode/")
+             (base32
+              "1gl2ap3w7zanbrn1k2bcf3f75lfpakp5dd0w8m1jy46hyvha7jpd")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/clrscode")
+    (synopsis "Typesets pseudocode as in Introduction to Algorithms")
+    (description
+     "This package allows you to typeset pseudocode in the style of
+@emph{Introduction to Algorithms}, Second edition, by Cormen, Leiserson,
+Rivest, and Stein.  The package was written by the authors.  You use the
+commands the same way the package's author did when writing the book, and your
+output will look just like the pseudocode in the text.")
+    (license license:lppl)))
+
 (define-public texlive-colorsep
   (package
     (name "texlive-colorsep")