summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-22 01:34:49 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-22 02:49:12 +0100
commita85c60278b326471f5e6a0f175255656659ccaa4 (patch)
treecc6520b6fc3920543686fc6f467654ce886a3f19 /gnu
parent9e396ab8d71781d5682871894df72f1e881db77a (diff)
downloadguix-a85c60278b326471f5e6a0f175255656659ccaa4.tar.gz
gnu: python-funcy: Don't use NAME in source URI.
* gnu/packages/python-xyz.scm (python-funcy)[source]: Hard-code NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bd0cea43f8..6242141139 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13490,13 +13490,13 @@ functions by partial application of operators.")
     (version "1.11")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/Suor/funcy/archive/" version
-                           ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Suor/funcy.git")
+             (commit version)))
        (sha256
-        (base32
-         "19nq2qqgavb054wqwi40wiq94sd22rgpvwbjlz6h3g8zv7b8dy14"))
-       (file-name (string-append name "-" version ".tar.gz"))))
+        (base32 "1s98vkjnq3zq71737hn8xa15kssvmy1sfzsll3vrlv53902418mw"))
+       (file-name (git-file-name name version))))
     (build-system python-build-system)
     (arguments
      `(#:phases