summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-01 23:29:04 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-04 04:20:06 +0200
commita926109d623b0faa0f09855e7647a629a45f979a (patch)
tree3015b6a241a85f13ac06cbc34699ff2919c4759e /gnu
parent7f12d8134e43eda122d47e11ef9c5d6879ebb32d (diff)
downloadguix-a926109d623b0faa0f09855e7647a629a45f979a.tar.gz
gnu: ndctl: Return #t from phases.
* gnu/packages/disk (ndctl)[arguments]: Rename inaccurately named
'autogen' phase to 'patch-FHS-file-names'. Explicitly return #t.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/disk.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 58c867d765..fa3a0431a5 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -630,14 +630,15 @@ passphrases.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'autogen
+         (add-after 'unpack 'patch-FHS-file-names
            (lambda _
              (substitute* "autogen.sh"
                (("/bin/sh") (which "sh")))
              (substitute* "git-version-gen"
                (("/bin/sh") (which "sh")))
              (substitute* "git-version"
-               (("/bin/bash") (which "bash"))))))
+               (("/bin/bash") (which "bash")))
+             #t)))
        #:make-flags
        (let ((out (assoc-ref %outputs "out")))
          (list (string-append "BASH_COMPLETION_DIR=" out