summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-05-06 11:14:53 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-05-06 22:34:36 +0530
commita993add16092fbe041e4f5ca48c00cd55e43640c (patch)
tree1f83c9955d14e84e9fc92822edeb6576e2685156 /gnu
parent7610c3ca5540a7d0946e15a765b35f8bf068316e (diff)
downloadguix-a993add16092fbe041e4f5ca48c00cd55e43640c.tar.gz
gnu: Add emacs-evil-surround.
* gnu/packages/emacs.scm (emacs-evil-surround): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 7e39c2a234..47fe0cc845 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4599,3 +4599,26 @@ selected frame.")
 mode for binding key chords to commands.  A key chord is defined as two keys
 pressed simultaneously or a single key quickly pressed twice.")
     (license license:gpl2+)))
+
+(define-public emacs-evil-surround
+  (package
+    (name "emacs-evil-surround")
+    (version "1.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/timcharper/evil-surround/archive/v"
+             version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0p572jgic3q1ia1nz37kclir729ay6i2f4sa7wnaapyxly2lwb3r"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-evil" ,emacs-evil)))
+    (home-page "https://github.com/timcharper/evil-surround")
+    (synopsis "Easily modify surrounding parantheses and quotes")
+    (description "@code{emacs-evil-surround} allows easy deletion, change and
+addition of surrounding pairs, such as parantheses and quotes, in evil mode.")
+    (license license:gpl3+)))