summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:36:29 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:07 +0200
commita9d292e276cc54ad8847e0cf1f759904bdbd2116 (patch)
tree5908926425c49990b24bb6f63d863e764f689f6e /gnu
parent5ca12f00c7abfa622bceeb718fe01b1c22ebd0bb (diff)
downloadguix-a9d292e276cc54ad8847e0cf1f759904bdbd2116.tar.gz
gnu: Add texlive-objectz.
* gnu/packages/tex.scm (texlive-objectz): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a2a9223d68..d2d6da5baa 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5223,6 +5223,24 @@ terms of recurrence relations.")
 mathematical function values.")
     (license license:lppl1.3c)))
 
+(define-public texlive-objectz
+  (package
+    (name "texlive-objectz")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/objectz/" "source/latex/objectz/"
+                   "tex/latex/objectz/")
+             (base32
+              "0a10ajlpmx6gfg4h9rvwf0q7zkb843pl5xfcsd9pzfg33245wbrz")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/objectz")
+    (synopsis "Macros for typesetting Object Z")
+    (description
+     "The package will typeset both Z and Object-Z specifications.")
+    (license license:lppl)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")