summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-05-25 22:16:37 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-26 00:19:39 +0200
commita9ef542552815e5509a55115154ea91fbb929031 (patch)
tree6a0721892c8cc2f03c40e58388374629cdc12178 /gnu
parent8f3f2c9b1bf594392930094065666d901c774e7d (diff)
downloadguix-a9ef542552815e5509a55115154ea91fbb929031.tar.gz
gnu: fetchmail: Update to 6.4.5.
* gnu/packages/mail.scm (fetchmail): Update to 6.4.5.
[arguments]: Remove obsolete ‘create-test-environment’ phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 101dcf52b4..1a01393cf4 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -347,7 +347,7 @@ to run without any changes.")
 (define-public fetchmail
   (package
     (name "fetchmail")
-    (version "6.4.1")
+    (version "6.4.5")
     (source
      (origin
        (method url-fetch)
@@ -355,21 +355,14 @@ to run without any changes.")
                            (version-major+minor version) "/"
                            "fetchmail-" version ".tar.xz"))
        (sha256
-        (base32 "1859wvfc9fq72mwp4njdiy0x89hnddlfr3nix71qqglcs0fz2crz"))))
+        (base32 "073bjh8qbvww7f5gbd6pq640qspi7dc6cjndvm0h2jcl0a90c3yk"))))
     (build-system gnu-build-system)
     (inputs
      `(("openssl" ,openssl)))
     (arguments
      `(#:configure-flags
        (list (string-append "--with-ssl="
-                            (assoc-ref %build-inputs "openssl")))
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'create-test-environment
-           (lambda _
-             ;; Fix ‘Cannot find absolute path for user's home directory’.
-             (setenv "HOME" "/tmp")
-             #t)))))
+                            (assoc-ref %build-inputs "openssl")))))
     (home-page "https://www.fetchmail.info/")
     (synopsis "Remote-mail retrieval and forwarding utility")
     (description