summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-08-29 18:59:10 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-08-29 19:09:54 +0200
commitaae704ddff32d938cc706b8eac1140af43a1fb55 (patch)
treea30191e69f425df5125187203f442b187eb356b6 /gnu
parentc3e5e1355b320bb3f2a6b0164af6f158b32263dd (diff)
downloadguix-aae704ddff32d938cc706b8eac1140af43a1fb55.tar.gz
gnu: next-gtk-webkit: Update to 1.3.0 and hide package.
* gnu/packages/web-browsers.scm (next-gtk-webkit): Update to 1.3.0.
We hide the package because it is not usable on its own, it's a necessary
backend for the `next' package.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web-browsers.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 366dc9da32..eb144ba3a2 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -365,10 +365,10 @@ vim editor and also easily configurable during runtime.  Vimb is mostly keyboard
 driven and does not detract you from your daily work.")
     (license license:gpl3+)))
 
-(define-public next-gtk-webkit
+(define next-gtk-webkit
   (package
     (name "next-gtk-webkit")
-    (version "1.2.2")
+    (version "1.3.0")
     (source
      (origin
        (method git-fetch)
@@ -377,7 +377,7 @@ driven and does not detract you from your daily work.")
              (commit version)))
        (sha256
         (base32
-         "1bif1k738knhifxhkn0d2x1m521zkx40pri44vyjqncp9r95hkbk"))
+         "0ibq30xrf871pkpasi8p9krn0pmd86rsdzb3jqvz3wnp4wa3hl9d"))
        (file-name (git-file-name "next" version))))
     (build-system glib-or-gtk-build-system)
     (arguments
@@ -399,7 +399,7 @@ driven and does not detract you from your daily work.")
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
        ("webkitgtk" ,webkitgtk-2.24)))
     (native-inputs
-     `(("gcc-7" ,gcc-7) ; needed because webkitgtk-2.22 and above are compiled with gcc-7
+     `(("gcc-7" ,gcc-7)   ; needed because webkitgtk-2.24 and above are compiled with gcc-7
        ("pkg-config" ,pkg-config)))
     (home-page "https://next.atlas.engineer")
     (synopsis "Infinitely extensible web-browser (user interface only)")