summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-03-04 16:19:19 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-03-04 16:19:19 +0200
commitab10e1086cf1e36330a55d05ee438b097c9fd626 (patch)
treecc10270418d51e894d3302a13a954c9114fc7e87 /gnu
parentb12974ec52de76d1420dd61aa5fcd075add5754d (diff)
downloadguix-ab10e1086cf1e36330a55d05ee438b097c9fd626.tar.gz
gnu: python-jedi: Allow test phase to be skipped.
* gnu/packages/python-xyz.scm (python-jedi)[arguments]: Wrap custom
'check phase tests with check for tests? keyword.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d9de9bc01c..fbc9ad688d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13945,9 +13945,11 @@ characters, mouse support, and auto suggestions.")
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _
-             (setenv "HOME" "/tmp")
-             (invoke "python" "-m" "pytest" "-vv"))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (setenv "HOME" "/tmp")
+               (invoke "python" "-m" "pytest" "-vv"))
+             #t)))))
     (native-inputs
      `(("python-pytest" ,python-pytest)
        ("python-docopt" ,python-docopt)))