summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-06-10 09:37:36 +0200
committerLudovic Courtès <ludo@gnu.org>2015-06-10 09:37:36 +0200
commitab999c25169d439639eccb5d17fc483ae2ead19c (patch)
tree1f91b7ac8fd0f07af3dd74c49acf328f031539bf /gnu
parentd0b62698c9bc55577ca7df9351c8f9afb2b52026 (diff)
downloadguix-ab999c25169d439639eccb5d17fc483ae2ead19c.tar.gz
gnu: commencement: Remove "debug" output of GCC-FINAL.
Fixes a regression introduced in 9063ef0.

* gnu/packages/commencement.scm (gcc-final)[outputs]: New field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/commencement.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 6cf56badbf..6a48fb640b 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -553,6 +553,12 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
   (package (inherit gcc-boot0)
     (name "gcc")
     (location (source-properties->location (current-source-location)))
+
+    ;; XXX: Currently #:allowed-references applies to all the outputs but the
+    ;; "debug" output contains disallowed references, notably
+    ;; linux-libre-headers.  Disable the debugging output to work around that.
+    (outputs (delete "debug" (package-outputs gcc-boot0)))
+
     (arguments
      `(#:guile ,%bootstrap-guile
        #:implicit-inputs? #f