summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPjotr Prins <pjotr.public01@thebird.nl>2018-12-18 11:16:52 +0000
committerLudovic Courtès <ludo@gnu.org>2018-12-21 18:07:28 +0100
commitaba368192a0b7f8ecdf26c6a4ed31cfb23147b4d (patch)
tree3d7cea92e869959e37235de71e27456cfff71465 /gnu
parentbdc61ff97d26d5d87020d07dfd43c0a552bd3449 (diff)
downloadguix-aba368192a0b7f8ecdf26c6a4ed31cfb23147b4d.tar.gz
gnu: python-rdflib: Update to 4.2.2.
* gnu/packages/rdf.scm (python-rdflib): Update to 4.2.2.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/rdf.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index 22ea21dd94..1c045b6ecc 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -299,7 +299,7 @@ ideal (e.g. in LV2 implementations or embedded applications).")
 (define-public python-rdflib
   (package
     (name "python-rdflib")
-    (version "4.1.2")
+    (version "4.2.2")
     (source
       (origin
         (method url-fetch)
@@ -307,15 +307,12 @@ ideal (e.g. in LV2 implementations or embedded applications).")
               "https://pypi.python.org/packages/source/r/rdflib/rdflib-"
               version
               ".tar.gz"))
-        (patches
-          ;; The patch has no effect under Python 3.
-          (search-patches "python2-rdflib-drop-sparqlwrapper.patch"))
         (sha256
           (base32
-            "0kvaf332cqbi47rqzlpdx4mbkvw12mkrzkj8n9l19wk713d4py9w"))))
+            "0398c714znnhaa2x7v51b269hk20iz073knq2mvmqp2ma92z27fs"))))
     (build-system python-build-system)
     (arguments
-     '(;; FIXME: Three test failures. Try uncommenting the below next update.
+     '(;; FIXME: Three test failures. Should be fixed next release.
        #:tests? #f))
        ;; #:phases
        ;; (modify-phases %standard-phases
@@ -323,7 +320,7 @@ ideal (e.g. in LV2 implementations or embedded applications).")
        ;;     (lambda _
        ;;       ;; Run tests from the build directory so python3 only
        ;;       ;; sees the installed 2to3 version.
-       ;;       (zero? (system* "nosetests" "--where=./build/src")))))
+       ;;       (zero? (system* "nosetests" "--where=./build/src")))))))
     (native-inputs
      `(("python-nose" ,python-nose)))
     (propagated-inputs