summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-10-11 10:38:46 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-14 17:07:37 +0200
commitb35936880d4823be3702bd4a7df9e9675446cca8 (patch)
tree8cc1a473ac76ab02009c586b2bab000bc2725e24 /gnu
parentf0f6f9f6cf81b54a3bdb2a40d67006a8df7ef00e (diff)
downloadguix-b35936880d4823be3702bd4a7df9e9675446cca8.tar.gz
gnu: Add python-pyqrcode.
* gnu/packages/python.scm (python-pyqrcode): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 1b62668904..1b1be11c68 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -23,7 +23,7 @@
 ;;; Copyright © 2016 Daniel Pimentel <d4n1@d4n1.org>
 ;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
 ;;; Copyright © 2016, 2017 Troy Sankey <sankeytms@gmail.com>
-;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
+;;; Copyright © 2016, 2017 ng0 <ng0@infotropique.org>
 ;;; Copyright © 2016 Dylan Jeffers <sapientech@sapientech@openmailbox.org>
 ;;; Copyright © 2016 David Craven <david@craven.ch>
 ;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
@@ -6613,6 +6613,26 @@ providing a clean and modern domain specific specification language (DSL) in
 Python style, together with a fast and comfortable execution environment.")
     (license license:expat)))
 
+(define-public python-pyqrcode
+  (package
+    (name "python-pyqrcode")
+    (version "1.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "PyQRCode" version))
+       (sha256
+        (base32
+         "1m9ln8k9v7dfbh1i81225hx5mdsh8mpf9g7r4wpbfmiyfcs7dgzx"))))
+    (build-system python-build-system)
+    (home-page
+     "https://github.com/mnooner256/pyqrcode")
+    (synopsis "QR code generator")
+    (description
+     "Pyqrcode is a QR code generator written purely in Python with
+SVG, EPS, PNG and terminal output.")
+    (license license:bsd-3)))
+
 (define-public python-seaborn
   (package
     (name "python-seaborn")