summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-22 10:38:25 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-23 16:37:34 +0300
commitb4b7b236fa4a19aa9985e57499d2714436e69cdc (patch)
tree67f5d0c59874065e71c0873e3819da55ec5cfe62 /gnu
parentb94534adf0fcbdcba92819e6b80c87d5dc228351 (diff)
downloadguix-b4b7b236fa4a19aa9985e57499d2714436e69cdc.tar.gz
gnu: ghc-8.10: Rewrite using G-exps.
* gnu/packages/haskell.scm (ghc-8.10)[arguments]: Rewrite using g-exps.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b99984406b..547af248e4 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -896,7 +896,7 @@ interactive environment for the functional language Haskell.")
     (arguments
      (substitute-keyword-arguments (package-arguments ghc-8.8)
        ((#:phases phases '%standard-phases)
-        `(modify-phases ,phases
+        #~(modify-phases #$phases
            (add-after 'unpack-testsuite 'patch-more-shebangs
              (lambda* (#:key inputs #:allow-other-keys)
                (let ((bash (assoc-ref inputs "bash")))