summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-08-22 13:31:37 +0200
committerLudovic Courtès <ludo@gnu.org>2016-09-12 15:27:46 +0200
commitb53fc2940fefc3829695f239f731ee6f03e538a2 (patch)
tree07b61997a0aa3ef8792f5c49238d3bdf30db3719 /gnu
parentd18197af7844151e38322605b11e0c75b18b55bf (diff)
downloadguix-b53fc2940fefc3829695f239f731ee6f03e538a2.tar.gz
gnu: Add python-django-simple-math-captcha.
* gnu/packages/django.scm: (python-django-simple-math-captcha)
(python2-django-simple-math-captcha): New variables.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/django.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 6acaae2485..b9232e28e8 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -96,3 +96,29 @@ to the @dfn{don't repeat yourself} (DRY) principle.")
          ;; When adding memcached mind: for Python 2 memcached <= 1.53 is
          ;; required.
          ,@(package-inputs base))))))
+
+(define-public python-django-simple-math-captcha
+  (package
+    (name "python-django-simple-math-captcha")
+    (version "1.0.7")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "django-simple-math-captcha" version))
+              (sha256
+               (base32
+                "0906hms6y6znjhpd0g4wmzv9vcla4brkdpsm4zha9zdj8g5vq2hd"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-django" ,python-django)))
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (home-page "https://github.com/alsoicode/django-simple-math-captcha")
+    (synopsis "Easy-to-use math field/widget captcha for Django forms")
+    (description
+     "A multi-value-field that presents a human answerable question,
+with no settings.py configuration necessary, but instead can be configured
+with arguments to the field constructor.")
+    (license license:asl2.0)))
+
+(define-public python2-django-simple-math-captcha
+  (package-with-python2 python-django-simple-math-captcha))