summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-04-08 01:12:51 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-04-09 00:06:03 +0200
commitb7daa450d93438e9c01fd72f930880e8d055921a (patch)
treec4ef173d51a25ec9633c0dd45b23dbaa96c892c7 /gnu
parentafd2d66f2a4a7e4e7157f0a785491295434964c8 (diff)
downloadguix-b7daa450d93438e9c01fd72f930880e8d055921a.tar.gz
gnu: sway: Update to 1.6.
* gnu/packages/wm.scm (sway): Update to 1.6.
[arguments]: Build with meson-next.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/wm.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index fca672c300..e80c776f6d 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1438,7 +1438,7 @@ modules for building a Wayland compositor.")
 (define-public sway
   (package
     (name "sway")
-    (version "1.5.1")
+    (version "1.6")
     (source
      (origin
        (method git-fetch)
@@ -1447,10 +1447,11 @@ modules for building a Wayland compositor.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1xsa3h8zhf29p0mi90baxpr76jkd9pd1gr97ky8cnjbcs4isj9j0"))))
+        (base32 "0vnplva11yafhbijrk68wy7pw0psn9jm0caaymswq1s951xsn1c8"))))
     (build-system meson-build-system)
     (arguments
-     `(#:phases
+     `(#:meson ,meson-next
+       #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'hardcode-paths
            (lambda* (#:key inputs #:allow-other-keys)