summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-22 10:37:00 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-23 16:37:34 +0300
commitb94534adf0fcbdcba92819e6b80c87d5dc228351 (patch)
treed753dfb678099608aa9e8462887310bed6797bcb /gnu
parent9e263027731b085640ddf48451e8f967ead283e4 (diff)
downloadguix-b94534adf0fcbdcba92819e6b80c87d5dc228351.tar.gz
gnu: ghc-8.10: Add phase unconditionally.
* gnu/packages/haskell.scm (ghc-8.10)[arguments]: Apply custom
'skip-failing-tests-i686 phase for all architectures.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm24
1 files changed, 10 insertions, 14 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 984aa33f6e..b99984406b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -910,20 +910,16 @@ interactive environment for the functional language Haskell.")
                  (("extra_files" all) (string-append "[" all))
                  (("\\]\\), " all)
                   (string-append all "expect_broken(0)], ")))))
-           ;; TODO: Turn this into an undconditional patch on the next rebuild.
-           ,@(if (string-prefix? "i686" (or (%current-target-system)
-                                                  (%current-system)))
-              '((add-after 'skip-more-tests 'skip-failing-tests-i686
-                 (lambda _
-                   (substitute* '("testsuite/tests/codeGen/should_compile/all.T")
-                     (("(test\\('T15155l', )when\\(unregisterised\\(\\), skip\\)" all before)
-                      (string-append before "when(arch('i386'), skip)")))
-                   ;; Unexpected failures:
-                   ;;    quasiquotation/T14028.run  T14028 [bad stderr] (dyn)
-                   (substitute* '("testsuite/tests/quasiquotation/all.T")
-                     (("unless\\(config.have_ext_interp, skip\\),")
-                      "unless(config.have_ext_interp, skip), when(arch('i386'), skip),")))))
-              '())))))
+           (add-after 'skip-more-tests 'skip-failing-tests-i686
+             (lambda _
+               (substitute* '("testsuite/tests/codeGen/should_compile/all.T")
+                 (("(test\\('T15155l', )when\\(unregisterised\\(\\), skip\\)" all before)
+                  (string-append before "when(arch('i386'), skip)")))
+               ;; Unexpected failures:
+               ;;    quasiquotation/T14028.run  T14028 [bad stderr] (dyn)
+               (substitute* '("testsuite/tests/quasiquotation/all.T")
+                 (("unless\\(config.have_ext_interp, skip\\),")
+                  "unless(config.have_ext_interp, skip), when(arch('i386'), skip),"))))))))
     (native-search-paths (list (search-path-specification
                                 (variable "GHC_PACKAGE_PATH")
                                 (files (list