summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorThomas Danckaert <post@thomasdanckaert.be>2017-03-06 15:33:34 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-03-06 23:51:23 +0100
commitba062b3ec4367919daf3ad458b88b710042fc678 (patch)
tree37b94874aa2bc86b7a281ea076e64fa2f14580cd /gnu
parent46d6219d41e98d20797fc075becdeecec73c7327 (diff)
downloadguix-ba062b3ec4367919daf3ad458b88b710042fc678.tar.gz
gnu: python-colorspacious: Run tests.
* gnu/packages/python.scm (python-colorspacious,
python2-colorspacious)[native-inputs]: Add python-nose.
[arguments]: Add custom 'check phase which runs nosetests.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 876ce900a1..a271ad46b7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3837,6 +3837,14 @@ To address this and enable easy cycling over arbitrary @code{kwargs}, the
     (build-system python-build-system)
     (propagated-inputs
      `(("python-numpy" ,python-numpy)))
+    (native-inputs
+     `(("python-nose" ,python-nose)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (zero? (system* "nosetests" "--all-modules" "-v" "colorspacious")))))))
     (home-page "https://github.com/njsmith/colorspacious")
     (synopsis "Python library for colorspace conversions")
     (description "@code{colorspacious} is a Python library that lets you