summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2018-11-29 21:13:44 -0600
committerEric Bavier <bavier@member.fsf.org>2018-11-30 00:21:25 -0600
commitc2d512d3d21550f68040d208afe260097df1650a (patch)
tree3c9ef9de9d27064bc52192f7b88a7cc9a1e23914 /gnu
parent95c1504758b16f9f509007c17d0dea88ac16f24e (diff)
downloadguix-c2d512d3d21550f68040d208afe260097df1650a.tar.gz
detox: Update to 1.3.0.
* gnu/packages/admin.scm (detox): Update to 1.3.0
[source]: Move to new upstream fork.
[inputs]: Remove libpopt.  Move flex to...
[native-inputs]: ...here, new field.  Add autoconf and automake.
[arguments]: Remove #:configure-flags.  Add 'delete-configure' phase.
[home-page]: Adjust for new upstream.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm33
1 files changed, 19 insertions, 14 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index c725fb9a2f..2f611432c7 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1340,25 +1340,30 @@ system is under heavy load.")
 (define-public detox
   (package
     (name "detox")
-    (version "1.2.0")
+    (version "1.3.0")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://sourceforge/detox/detox/" version
-                                  "/detox-" version ".tar.bz2"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/dharple/detox.git")
+                    (commit (string-append "v" version))))
               (sha256
                (base32
-                "1y6vvjqsg54kl49cry73jbfhr04s7wjs779vrr9zrq6kww7dkymb"))))
+                "1dd608c7g65s5lj02cddvani3q9kzirddgkjqa22ap9d4f8b9xgr"))))
     (build-system gnu-build-system)
-    ;; Both flex and popt are used in this case for their runtime libraries
-    ;; (libfl and libpopt).
-    (inputs
-     `(("flex" ,flex)
-       ("popt" ,popt)))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("flex" ,flex)))
     (arguments
-     `(#:configure-flags `(,(string-append "--with-popt="
-                                           (assoc-ref %build-inputs "popt")))
-       #:tests? #f))                    ;no 'check' target
-    (home-page "http://detox.sourceforge.net")
+     `(#:tests? #f                    ;no 'check' target
+       #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'delete-configure
+                    ;; The "configure" script is present, but otherwise the
+                    ;; project is not bootstrapped: missing install-sh and
+                    ;; Makefile.in, so delete it so the bootstrap phase will
+                    ;; take over.
+                    (lambda _ (delete-file "configure") #t)))))
+    (home-page "https://github.com/dharple/detox")
     (synopsis "Clean up file names")
     (description
      "Detox is a program that renames files to make them easier to work with