summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-11-27 21:42:34 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-11-30 15:50:32 +0100
commitc7174a75bff88f48bc6f6f9a56b681d52956e40b (patch)
tree9e5aed6651d4b662d751778072386f96ed80c177 /gnu
parent05fe0a587a9d470c7bd3e66ac2178cf3389dbd37 (diff)
downloadguix-c7174a75bff88f48bc6f6f9a56b681d52956e40b.tar.gz
gnu: ocaml-ulex: Remove package.
* gnu/packages/ocaml.scm (ocaml-ulex): Remove deprecated package.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm30
1 files changed, 0 insertions, 30 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 663c385d95..d2b7ca854f 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1970,36 +1970,6 @@ format.  It can process XML documents without a complete in-memory
 representation of the data.")
     (license license:isc)))
 
-(define-public ocaml-ulex
-  (package
-    (name "ocaml-ulex")
-    (version "1.2")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/whitequark/ulex.git")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "08yf2x9a52l2y4savjqfjd2xy4pjd1rpla2ylrr9qrz1drpfw4ic"))))
-    (build-system ocaml-build-system)
-    (arguments
-     `(#:phases (modify-phases %standard-phases (delete 'configure))
-       #:tests? #f
-       #:make-flags
-       (list "all.opt"
-             (string-append "OCAMLBUILD=ocamlbuild -byte-plugin "
-                            "-cflags -I," (assoc-ref %build-inputs "camlp4")
-                            "/lib/ocaml/site-lib/camlp4"))))
-    (native-inputs
-     `(("camlp4" ,camlp4)
-       ("ocamlbuild" ,ocamlbuild)))
-    (home-page "http://www.cduce.org/download.html#side")
-    (synopsis "Lexer generator for Unicode and OCaml")
-    (description "Lexer generator for Unicode and OCaml.")
-    (license license:expat)))
-
 (define-public ocaml-gen
   (package
     (name "ocaml-gen")