summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
commitcb05df4bca8e636e46e8a6f085592711e4e337ba (patch)
tree78790141bdc5d89f0c132a72c433c3aff17f7887 /gnu
parentb5b1dc96eb9356e708e284640ae400e7069b9a99 (diff)
downloadguix-cb05df4bca8e636e46e8a6f085592711e4e337ba.tar.gz
gnu: Add ghc-config-schema.
* gnu/packages/haskell-xyz.scm (ghc-config-schema): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 0f0b59899f..5cc72bacb3 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -2378,6 +2378,35 @@ and incidental whitespace will remain unchanged.  The library aims to produce
 human-readable error messages when things go wrong.")
     (license license:bsd-3)))
 
+(define-public ghc-config-schema
+  (package
+    (name "ghc-config-schema")
+    (version "1.2.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "config-schema" version))
+       (sha256
+        (base32 "10mp76j2gxcb51865lb6cf3nkc2nc7fwarkghb6yz71q6sbrg3yx"))))
+    (build-system haskell-build-system)
+    (arguments
+     `(#:cabal-revision ("3"
+                         "16rwj3vcafq4fqqh5rq1na1g4syk63kki2gjinb6yj3h8s59vpp7")))
+    (inputs
+     (list ghc-config-value
+           ghc-free
+           ghc-kan-extensions
+           ghc-semigroupoids))
+    (properties '((upstream-name . "config-schema")))
+    (home-page "https://github.com/glguy/config-schema")
+    (synopsis "Schema definitions for the config-value package")
+    (description
+     "This package makes it possible to define schemas for use when loading
+configuration files using the config-value format.  These schemas can be used to
+process a configuration file into a Haskell value or to automatically generate
+documentation for the file format.")
+    (license license:isc)))
+
 (define-public ghc-config-value
   (package
     (name "ghc-config-value")