summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-03-23 15:37:24 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-03-23 15:37:24 +0100
commitcb4805e34c9997edca14743516b9a0fde6303d1c (patch)
treee42d4bcf3f3efd44e4a1654f495cfcf0280eccba /gnu
parent0371b345e8bffb0770b1a02ddd1c248f90566e04 (diff)
downloadguix-cb4805e34c9997edca14743516b9a0fde6303d1c.tar.gz
gnu: gfortran: Change default version to gfortran-5.
* gnu/packages/gcc.scm (gfortran): Point to gfortran-5.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gcc.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 9376679f14..eb7a81341c 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -401,7 +401,8 @@ Go.  It also includes runtime support libraries for these languages.")
                                        "gcc-5.0-libvtv-runpath.patch"))))))
 
 ;; Note: When changing the default gcc version, update
-;;       the gcc-toolchain-* definitions accordingly.
+;;       the gcc-toolchain-* definitions and the gfortran definition
+;;       accordingly.
 (define-public gcc gcc-5)
 
 (define-public (make-libstdc++ gcc)
@@ -521,9 +522,9 @@ as the 'native-search-paths' field."
 (define-public gfortran
   ;; Note: Update this when GCC changes!  We cannot use
   ;; (custom-gcc gcc "fortran" …) because that would lead to a package object
-  ;; that is not 'eq?' with GFORTRAN-4.9, and thus 'fold-packages' would
-  ;; report two gfortran@4.9 that are in fact identical.
-  gfortran-4.9)
+  ;; that is not 'eq?' with GFORTRAN-5, and thus 'fold-packages' would
+  ;; report two gfortran@5 that are in fact identical.
+  gfortran-5)
 
 (define-public gfortran-5
   (custom-gcc gcc-5 "gfortran" '("fortran")