summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-05 16:49:44 -0600
committerEric Bavier <bavier@member.fsf.org>2015-03-06 08:13:29 -0600
commitd0662af9556d19dedfc3cc9595c0169f0ed967f4 (patch)
tree19bd7eb4eee59a4cc12f64b88bc3620169153297 /gnu
parentd4dfe333dfcd906019f63172a27c8f984fd804e6 (diff)
downloadguix-d0662af9556d19dedfc3cc9595c0169f0ed967f4.tar.gz
gnu: Add Test-Directory.
* gnu/packages/perl.scm (perl-test-directory): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 1cea293b52..8d9e9f6a2c 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1385,6 +1385,30 @@ functions")
     ;; license, any version, ..."
     (license gpl3+)))
 
+(define-public perl-test-directory
+  (package
+    (name "perl-test-directory")
+    (version "0.041")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/S/SA/SANBEG/"
+                           "Test-Directory-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1ncql08cizhicbxwd753b4czns8nlcnlw0zfjcfrbdd41x4j6hqr"))))
+    (build-system perl-build-system)
+    (native-inputs `(("perl-test-exception" ,perl-test-exception)))
+    (home-page "http://search.cpan.org/dist/Test-Directory")
+    (synopsis "Perl extension for maintaining test directories")
+    (description "Testing code can involve making sure that files are created
+and deleted as expected.  Doing this manually can be error prone, as it's easy
+to forget a file, or miss that some unexpected file was added.  This module
+simplifies maintaining test directories by tracking their status as they are
+modified or tested with this API, making it simple to test both individual
+files, as well as to verify that there are no missing or unknown files.")
+    (license (package-license perl))))
+
 (define-public perl-test-exception
   (package
     (name "perl-test-exception")