summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-05-03 19:34:34 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-05-07 18:16:59 +0200
commitd1b1e21ded25425c4c706943ce1eb7356c9e305a (patch)
tree4be41e8c0e262972a0354d49313165b4159a3148 /gnu
parent9a2251fb5a86806381a5297f8245d8ec8b4e2980 (diff)
downloadguix-d1b1e21ded25425c4c706943ce1eb7356c9e305a.tar.gz
gnu: Add sgp4.
* gnu/packages/astronomy.scm (sgp4): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm35
1 files changed, 34 insertions, 1 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index c7d27a58d3..6d1c4ddfe6 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -4,7 +4,7 @@
 ;;; Copyright © 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2019 by Amar Singh <nly@disroot.org>
 ;;; Copyright © 2020 R Veera Kumar <vkor@vkten.in>
-;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2020, 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -792,6 +792,39 @@ provide you with detailed information about each pass.")
     (home-page "http://gpredict.oz9aec.net/index.php")
     (license license:gpl2+)))
 
+(define-public sgp4
+  ;; No tagged releases, use commit directly.
+  (let ((commit "ca9d4d97af4ee62461de6f13e0c85d1dc6000040")
+        (revision "1"))
+    (package
+      (name "sgp4")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/dnwrnr/sgp4")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1xwfa6papmd2qz5w0hwzvijmzvp9np8dlw3q3qz4bmsippzjv8p7"))))
+      (build-system cmake-build-system)
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (replace 'check
+             (lambda _
+               ;; Tests fails, probably because of a few "(e <= -0.001)" errors.
+               ;; Or maybe this is not the right way to run the tests?
+               ;; (invoke "runtest/runtest")
+               #t)))))
+      (home-page "https://github.com/dnwrnr/sgp4")
+      (synopsis "Simplified perturbations models library")
+      (description
+       "This is a library implementing the simplified perturbations model.
+It can be used to calculate the trajectory of satellites.")
+      (license license:asl2.0))))
+
 (define-public indi
   (package
     (name "indi")