summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-01 20:13:35 +0200
committerMarius Bakke <marius@gnu.org>2022-09-01 22:22:51 +0200
commitd2bddfd736196824cae2d1feaf3bf8997cd86cc3 (patch)
tree3dc00a55d099f6cdd4322fafe45df4db01e81c35 /gnu
parentced93c14d17289137188b1ca1cc828085441bfaf (diff)
downloadguix-d2bddfd736196824cae2d1feaf3bf8997cd86cc3.tar.gz
gnu: glade: Use G-expression.
* gnu/packages/gnome.scm (glade3)[arguments]: Convert to gexp.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm47
1 files changed, 24 insertions, 23 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 64363fe842..c571682e8f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3132,30 +3132,31 @@ API add-ons to make GTK+ widgets OpenGL-capable.")
                 "171x7vshhw0nqgnhkcaqfylpr5qrmhclwmkva6wjm5s9m2pavj9i"))))
     (build-system meson-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'skip-gtk-update-icon-cache
-           ;; Don't create 'icon-theme.cache'.
-           (lambda _
-             (substitute* "meson_post_install.py"
-               (("gtk-update-icon-cache") "true"))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'skip-gtk-update-icon-cache
+            ;; Don't create 'icon-theme.cache'.
+            (lambda _
+              (substitute* "meson_post_install.py"
+                (("gtk-update-icon-cache") "true"))))
 
-         ,@(if (this-package-input "gjs")
-               '()
-               '((add-after 'unpack 'skip-gjs-test
-                   (lambda _
-                     ;; When the optional dependency on GJS is missing, skip
-                     ;; the GJS plugin tests.
-                     (substitute* "tests/modules.c"
-                       (("g_test_add.*JavaScript.*" all)
-                        (string-append "// " all "\n")))
-                     (delete-file "tests/catalogs/gjsplugin.xml")))))
-         (add-before 'check 'pre-check
-           (lambda _
-             (setenv "HOME" "/tmp")
-             ;; Tests require a running X server.
-             (system "Xvfb :1 &")
-             (setenv "DISPLAY" ":1"))))))
+          #$@(if (this-package-input "gjs")
+                 '()
+                 '((add-after 'unpack 'skip-gjs-test
+                     (lambda _
+                       ;; When the optional dependency on GJS is missing, skip
+                       ;; the GJS plugin tests.
+                       (substitute* "tests/modules.c"
+                         (("g_test_add.*JavaScript.*" all)
+                          (string-append "// " all "\n")))
+                       (delete-file "tests/catalogs/gjsplugin.xml")))))
+          (add-before 'check 'pre-check
+            (lambda _
+              (setenv "HOME" "/tmp")
+              ;; Tests require a running X server.
+              (system "Xvfb :1 &")
+              (setenv "DISPLAY" ":1"))))))
     (inputs
      (append
       ;; GJS depends on Rust, which is x86_64-only so far, so remove the GJS