summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRaphaël Mélotte <raphael.melotte@mind.be>2020-11-06 20:16:20 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-11 17:48:03 +0100
commitd2bf896155851fee524b045a790b949ea6863c76 (patch)
tree3dc6c3c7c74a72db2c037f661936b5f953f3cf4f /gnu
parentb9772f62416d5f78f7f377549211f47e9ba1b494 (diff)
downloadguix-d2bf896155851fee524b045a790b949ea6863c76.tar.gz
gnu: eid-mw: Build reproducibly.
* gnu/packages/security-token.scm (eid-mw)[arguments]: Add
a "make-reproducible" phase to set build date to the epoch.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/security-token.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index cf6bf18373..162868ad7a 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -139,7 +139,13 @@ readers and is needed to communicate with such devices through the
              (substitute* "scripts/build-aux/genver.sh"
                (("/bin/sh") (which "sh"))
                (("^(GITDESC=).*" _ match) (string-append match ,version "\n")))
-             (invoke "sh" "./bootstrap.sh"))))))
+             (invoke "sh" "./bootstrap.sh")))
+         (add-after 'unpack 'make-reproducible
+           (lambda _
+             (substitute* "scripts/mac/create-vers.sh"
+               (("NOW=.*")
+                "NOW=1970-01-01\n"))
+             #t)))))
     (synopsis "Belgian eID Middleware")
     (description "The Belgian eID Middleware is required to authenticate with
 online services using the Belgian electronic identity card.")