summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2023-06-20 21:00:54 -0400
committerLudovic Courtès <ludo@gnu.org>2023-07-18 14:06:50 +0200
commitd2c6d1d818ebd0ebeb94252e439f80e59e850207 (patch)
tree867bb6e7ac2f1c6af956ab323c9e96c5168499ff /gnu
parent377dc49f2443644866b180b3b162d7d4aab88531 (diff)
downloadguix-d2c6d1d818ebd0ebeb94252e439f80e59e850207.tar.gz
gnu: Add firejail.
* gnu/packages/linux.scm (firejail): New variable.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e099c5cc83..39503de6ff 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -95,6 +95,7 @@
   #:use-module (gnu packages acl)
   #:use-module (gnu packages admin)
   #:use-module (gnu packages algebra)
+  #:use-module (gnu packages apparmor)
   #:use-module (gnu packages audio)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages avahi)
@@ -10165,6 +10166,42 @@ suggestions from various sources, including:
 This tool supports checking Kconfig options and kernel cmdline parameters.")
     (license license:gpl3)))
 
+(define-public firejail
+  (package
+    (name "firejail")
+    (version "0.9.72")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/netblue30/firejail/releases/download/" version
+                    "/firejail-" version ".tar.xz" ))
+              (sha256
+               (base32
+                "1x77xy1mwfgjrcsymdda82bjnqgl7z2yymcb10mzd1zwik27gqc2"))))
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     (with-directory-excursion "test"
+                       (invoke "make"))))))))
+    (build-system gnu-build-system)
+    (inputs
+     (list apparmor xdg-dbus-proxy))
+    (synopsis "Linux namespaces sandbox program")
+    (description
+     "Firejail is a SUID sandbox program that reduces the risk of security
+breaches by restricting the running environment of untrusted applications
+using Linux namespaces, seccomp-bpf and Linux capabilities.  The software
+includes sandbox profiles for a number of common Linux programs.  Firejail
+should be added to the list of setuid programs in the system configuration to
+work properly.")
+    (home-page "https://github.com/netblue30/firejail")
+    (supported-systems
+     (filter (cut string-suffix? "-linux" <>) %supported-systems))
+    (license license:gpl2+)))
+
 (define-public edac-utils
   (package
     (name "edac-utils")