summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2016-06-19 18:56:56 -0400
committerKei Kebreau <kei@openmailbox.org>2016-06-20 09:03:30 -0400
commitd2cc38b7135b26793870d07751bdbd467296d93b (patch)
tree1db6136e20ad232a0c2951c5b8981aa2cefab5c3 /gnu
parent3099354dd4528a1889e3da2b5515bbf0efad4ce0 (diff)
downloadguix-d2cc38b7135b26793870d07751bdbd467296d93b.tar.gz
gnu: Add quesoglc.
* gnu/packages/game-development.scm (quesoglc): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/game-development.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 56617bb895..b11285ab54 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -34,6 +34,8 @@
   #:use-module (gnu packages curl)
   #:use-module (gnu packages databases)
   #:use-module (gnu packages documentation)
+  #:use-module (gnu packages fontutils)
+  #:use-module (gnu packages fribidi)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnunet)
   #:use-module (gnu packages guile)
@@ -432,3 +434,28 @@ It offers the following features:
   import into a database.
 @end enumerate")
     (license license:gpl2+)))
+
+(define-public quesoglc
+  (package
+    (name "quesoglc")
+    (version "0.7.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/" name "/" version "/"
+                                  name "-" version "-free.tar.bz2"))
+              (sha256
+               (base32
+                "08ddhywdy2qg17m592ng3yr0p1ih96irg8wg729g75hsxxq9ipks"))))
+    (build-system gnu-build-system)
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("fontconfig" ,fontconfig)
+              ("freeglute" ,freeglut)
+              ("fribidi" ,fribidi)
+              ("glew" ,glew)))
+    (home-page "http://quesoglc.sourceforge.net")
+    (synopsis "Implementation of the OpenGL Character Renderer (GLC)")
+    (description
+     "The OpenGL Character Renderer (GLC) is a state machine that provides
+OpenGL programs with character rendering services via an application programming
+interface (API).")
+    (license (list license:expat license:lgpl2.1+))))